Announcement

Collapse
No announcement yet.

h264 export problems - still buggy?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • h264 export problems - still buggy?

    Hi, is it just me or davinci resolve really sucks when it comes to exporting h264 files? When I don't use "youtube"/"vimeo" preset or default settings? As soon as I want to output any higher bitrate than default 10mbps, it fails with "Failed to encode the video frame" message.

    I thought that it was just a bug in resolve 15, but as I installed latest studio version, problem is still here.
    Is there any other workaround for h264 final delivery files as exporting to DNX and exporting from premiere or handbrake?

  • #2
    It might be an issue with your system. Iíve never had issues with exporting to H264 nor H265, only when a video file turned out to be corrupted.

    I would suggest sending a system log and a resolve log to Blackmagicís support team to see if they can determine the issue.
    Darren Hartman
    Asyn Film | Banana Stand Media

    Comment


    • #3
      Use a MP4 format instead of Quicktime with a H264 or H265 codec and you should not have the issue. From what I have learned, this is a QT container issue.

      Comment


      • #4
        Are you on Windows 7? If so, that is the problem. Fortunately, in Davinci 16, there's a solution, assuming you have an Nvidia graphics card. On the deliver page choose:

        Format: MP4
        Codec: H.264
        Encoder: NVIDIA

        Davinci will now use the Nvidia graphics card for the encoding and you won't get that error.

        Comment


        • #5
          Thanks for the info guys!
          I am on win7 system. Apparently it helps a bit if I change to mp4 export - I dont get a error if I put in custom bitrate, but weirdly, no matter how high I set it to, I always get the file encoded to ~5mbps.
          If I select quality at "best" I still get that same error.
          I can't find where to set encoder to nvidia, but it is rendering with graphics card (I can see it working with gpu-z when exporting).
          Same thing happens if I select "H.264 Master" preset.
          I have a bit older gpu (660ti w.3gb ram) running on latest drivers. Could this be problem? I know it's not the fastest one, but it just doesn't want to die

          Comment


          • #6
            Since you say you're using the latest Nvidia driver, the fact that you don't see the Encoder option is probably because of your old graphics card.

            Here's another thing you can try which will give you better quality than the 5mbps H.264.
            It's encoding with H.263, the predecessor to H.264. Set up your render like this:

            Format: Quicktime
            Codec: MPEG
            Type: MPEG4Video
            Quality: Best

            You will be pleasantly surprised how good this looks and how fast it renders. And it's fully compatible with all media players out there.

            Comment


            • #7
              This is an error you get when the Cuda compute of your GPU is not supported anymore by the encoding software. The solution is to use OpenCL or upgrade your card.

              Comment


              • #8
                Never convert to h264 using Resolve. It is bad.
                Better export as DNxHD and after that using handbrake.fr to convert it to h264. 2-Pass. And you can also crop if neccesary. Because DNxHD only support 16:9 (I believe).

                Comment


                • #9
                  I second that, my standard advice in such cases: export your film in a mezzanine codec, like Cineform or DNxHD/HR and do the encoding in Handbrake (free) with a high bitrate.

                  Comment

                  Working...
                  X