No announcement yet.

T5 not detected after in-camera format (exFAT)

  • Filter
  • Time
  • Show
Clear All
new posts

  • T5 not detected after in-camera format (exFAT)

    I got a new Samsung T5, successfully tested it for sped on a Mac at work and a PC at home, then formatted it using the camera, I think cause the camera couldn't see it. I chose "exFAT", since the only other option was "OS X Extended".

    The drive is still working in the camera (BMPCC4K), but now my Windows 10 computer does not see it at all when I plug it in. I tested all USB ports, and it doesn't even show up in the "Disk Management" utility where I usually initialize drives that don't show up in windows explorer. Also tried a Samsung TV just to see if that worked but the TV also didn't even flinch when I plugged it in.

    I did a few searches and tried using HFS+ to no avail. I am kinda worried that I may need to RMA. Anyone know a solution?

  • #2
    Tried a few other things, but nothing detects the drive at all so far...