Announcement

Collapse
No announcement yet.

Help! Firmware 1.93 update gone wrong :/

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Help! Firmware 1.93 update gone wrong :/

    I just updated my BMCC to 1.93, it took about 10mins and I see picture with new features! I then turn off, unplug and turn back on to find the picture flickers. I turn the camera off/on again only to find it won't turn back on. ( I have this plugged in )

    The screen flashes just for a sec when I try to boot it up, but nothing after - even when plugging back into the computer to update again.

    Has this happened to anyone else or could provide assist before I contact Blackmagic?

    Thanks!

  • #2
    Re flickering screen. This is from the readme that accompanies every firmware update:
    "After loading the software on the Blackmagic Cinema Camera EF or MFT, you may notice a slight flickering on the built-in LCD screen. This is normal and expected behaviour. The flickering will go away after a few minutes of operation."

    As for you screen being blank after a restart, not sure why that is. Could you try installing an older firmware and then upgrading again. To do this you'll have to download a previous version (1.8.2), uninstall the current version (1.9.3) on your computer and then install (1.8.2). Connect the camera and update it. Does the screen come on again? Then repeat the process (uninstall, install) with 1.9.3.
    Adam Roberts
    www.adamroberts.net

    Comment


    • #3
      Don't hold power button too long, it makes stuff go awry. Momentary on, long press off
      http://www.youtube.com/user/madmohawkfilms

      Comment


      • #4
        Since we are shooting tomorrow I hope you fixed it but I love that the advice a gave in our phone call is exactly the same as the forum info.

        Comment


        • #5
          I had the same thing
          Update to 1 9 3 failed at the middle, don't know why.
          Camera just went to black screen and did not power up.
          I connected it with USB again and suddenly update started again and success.
          After that screen is just blanked and nothing.
          I run update again and success.
          And only from that point camera started and was usable.
          Very very strange behavior during update.
          Never faced such weird stuff. Hope no one will.

          Comment

          Working...
          X